BusinessLink/WEB and Strategi Applet Requirements

Product: Strategi
Modified Date:


The iSeries 400 5250 communications applet is certified 100% Java by Sun Microsystems. In short, this qualification means that the applet should function properly on any platform that is 100% Java compliant and has a properly configured TCP/IP connection.

How it Works
When a browser client enters the URL of the page containing the HTML statements which load the applet, the sequence of events is as follows:

  • The applet is transferred to the local PC on the same TCP/IP port that loaded the page.
  • The applet initializes, starts, and attempts to make a connection back to the same URL specified on the request using TCP/IP port 43856 (or port 80 for Strategi systems with HTTP Tunneling configured).
  • The user is prompted for a user name and passphrase. If a valid user name and password is specified, the applet obtains a 5250 session and presents the user with a iSeries 400 signon screen.
Applet Requirements

The following list describes the environment required for the 5250 Java applet to function properly:

  • The client must have a 100% compliant JVM (Java Virtual Machine) installed.
  • The client browser must support the use of the JVM.
  • Currently supported browsers are all versions of Internet Explorer (6, 7, 8, 9, 10, 11), Firefox ESR 52 , and Safari on Mac OsX.
  • The connection that the applet establishes is used for stream communications. In other words, the established connection must not be interrupted or terminated by firewalls, proxies or timeouts/disconnects on Internet connections. Doing so will terminate the connection (compares to pulling the power cable from your PC).
  • For BusinessLink/WEB systems, if the coprocessor is behind a firewall, port 43856 must be open for inbound and outbound TCP traffic.
  • For Strategi systems, if the iSeries 400 is behind a firewall, port 43856 must be open for inbound and outbound TCP traffic or the applet must be configured to use HTTP Tunneling. Adding the applet parameter statement '<param name=http_tunnel value="fallback">' will allow the applet to first try port 43856 and revert to port 80 if the initial connection attempt on port 43856 fails.

Common Errors/Problems and Causes

Error:
Unable to make TCP/IP connection.

Cause:
You are attempting access from behind a firewall that is blocking the connection or the applet cannot communicate on port 43856 due to improper workstation TCP/IP setup.

Solution:
Open port 43856 to allow both inbound and outbound traffic and verify that TCP/IP is correctly configured on your workstation. In some network environments, workstations must be configured to use a Winsock proxy client. Most HTTP proxies do not provide the TCP/IP support required of the applet.

Detail
Many network administrators are concerned about opening ports above 1024 to incoming traffic, for fear of attempts at unauthorized access to their system. There is, however, a solution which severely restricts access on those ports, by limiting access to a specific IP address (in this case, the IP address of the iSeries 400). This solution is called "filtering by address". Filtering by address lets you restrict the flow of packets based on the source and/or destination addresses of the packets, without having to consider what protocols are involved. Such filtering can be used to allow certain external hosts (such as the BusinessLink Webserver) to talk to certain internal hosts (your network), and to prevent an outsider from injecting "forged" packets (packets handcrafted so they appear to come from somewhere other than their true source) into your network. (An excellent discussion of this can be found in the book "Building Internet Firewalls" by D. Brent Chapman and Elizabeth D. Zwickey, O'Reilly and Associates, Inc.)

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Problem:
Cannot retrieve files in 'available files' window.

Cause:
You have a popup blocker installed.

Solution:
Disable all popup blockers or allow popups on this URL.

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Applet Operation Requirement Checklist

[ ]  JVM is installed.
[ ]  Browser version is IE6+, Firefox ESR, or Safari on Mac OSx.
[ ]  Workstation TCP/IP is configured properly.
[ ]  Workstation TCP/IP connection is stable.
[ ]  Workstation has Winsock client installed if using a proxy server.
[ ]  Firewall (if present) has port 43856 open for TCP traffic.
[ ]  Firewall (if present) supports stream I/O.
[ ]  Firewall (if present) does not terminate connections after a specified period of time.


** End of Technical Support Bulletin **