License Key Error Information

Product: Strategi
Modified Date:


Listed below are messages that you may receive in regards to your license key along with detailed information about their causes.

Usage limit threshold exceeded for product 7O77SGI.
Grace period expired. Requesting user not added.
STRATEGI ALERT: Maximum number of threads limited to __ by system license.
Usage limit of __ exceeded. Grace period expires in __ days on _/_/01
Expiration date will be reached in __ days on __/__/01.
[ERR!] Refused connection, max __ active
Expiration date 12/31/04 was reached.


**Messages sent to QSYSOPR**

1. Message ID: CPI9E19

Usage limit threshold exceeded for product 7O77SGI.

Cause:
This message is sent if your Strategi connections have exceeded the Threshold limit indicated in the Strategi User License (Feature 5002). The Threshold number is usually defaulted to be 2 less users than your licensed limit. (i.e., System licensed for 16 users, the threshold is usually set to 14). The intention is that you will be notified when you are getting close to your licensed limit. Once 14 different users have connected this message will be sent to QSYSOPR.

Fix:
You can change this threshold number to be higher or lower.
  • At an iSeries command line enter: WRKLICINF
  • Scroll down to Strategi license listed as "Feature 5002 Strategi Users"
  • Enter a 2 in the option field
  • Once the license information is listed on the screen, press ENTER to display additional fields
  • In the Threshold field, change it to the desired number

  • 2. Message ID: CPF9E71

    Grace period expired. Requesting user not added.

    Cause:
    A user attempted to connect to Strategi, but that connection exceeded your licensed limit and usage has been exceeding the licensed limit for longer than the grace period allows. A user connecting to the applet would have received a message "All licenses currently in use. Please try again later."

    Fix:
    You may need to purchase additional licenses in order to accommodate your user needs. Please see your sales representative.

    3. Message ID: CPF9898 (general message ID)

    STRATEGI ALERT: Maximum number of threads limited to __ by system license.

    Cause:
    This message is sent upon startup of Strategi. Threads refers to HTTP Threads, which will vary depending on your system size. Please see Strategi Connections Defined TSB for more information.

    Fix:
    Change the Strategi Values for THREADS and DYNAMICTHREADS to equal no more than your allowed number of threads per the TSB mentioned above. THREADS is the initial number to start and DYNAMICTHREADS is the maximum number of additional threads that can be started automatically when needed.

    4. Message ID: CPF9E72

    Usage limit of __ exceeded. Grace period expires in __ days on __/__/01

    Cause:
    Built into the Strategi license is a one-time Grace Period that will allow you to exceed your licensed number of uses by half. For users this grace period is up to 14 days and for HSM servers it is 60 days.

    For example, if you are licensed for 16 users, once a 17th user starts a connection your grace period of 2 weeks begins. Strategi will allow up to 24 total users to connect during this grace period. Once this grace period expires you will be limited to your 16 licensed users.

    Fix:
    You may need to purchase additional licenses in order to accommodate your user needs. Please see your sales representative.

    5. Message ID: CPI9E76 (general message ID)

    Expiration date will be reached in __ days on __/__/01.

    Cause:
    Your Strategi license key is about to expire.

    Fix:
    Your Strategi license key needs to be renewed and added to your system.

    6. Message ID: CPF9E73

    Expiration date __/__/__ was reached.

    Cause:
    Your Strategi license key has expired.

    Fix:
    Your Strategi license key needs to be renewed and applied to your system.



    **Messages sent to COMSSERVER**
    Divider
    7. Message ID: CPF9897

    [ERR!] Refused connection, max __ active

    Cause:
    The number of virtual sessions has exceeded your maximum number of virtual sessions. Strategi Special Value SESSIONS. Users may receive the message "No server response (TCP/IP ok)" upon launching the applet.

    Fix:
  • Go to the Strategi Main Menu
  • Work With Strategi Values
  • Go to special value SESSIONS
  • Enter a 2 to change
  • Increase the number currently entered

    Note: Strategi must be restarted before this change will take effect.


  • ** End of Technical Support Bulletin **